Scheduled maintenance for VPS Infrastructure
Incident Report for Joe's Datacenter, LLC
Resolved
This incident has been resolved.
Posted Mar 07, 2021 - 06:16 CST
Monitoring
We are now starting our VPS and Cloud infrastructure scheduled maintenance. We are in the process of migrating all customer Virtual Machines from our current cloud environment running on OnApp to our new cloud infrastructure powered by OpenStack and Virtuozzo VHI.

We will be performing migrations during these times:
03-06-2021 12:00a.m. - 5:00a.m. Central Time
03-07-2021 12:00a.m. - 5:00a.m. Central Time

Customers will be migrated in batches. The expected migration time for each customer during this maintenance window will vary depending on the size of the Virtual Machine. We estimate that the average amount of downtime will be around 45 minutes. We are prepared to fully migrate the Virtual Machines with no action necessary from customers. We will notify you when we start the migration of your virtual machine and when the migration is completed. Technicians will manually verify the migration was successful before marking the ticket completed. The original Virtual Machine data will remain on the old infrastructure for several days before being deleted in case a rollback is needed.

The virtual hardware will most likely change and it may be necessary for our technicians to log into the virtual machine and verify or fix system drivers, boot partition information, and/or network settings. These changes will be scripted but manual steps might be necessary by technicians during this maintenance window. If you do not feel comfortable with us logging in and making these changes please contact us asap so we can work with you to make the appropriate changes before the migration.

Some Benefits of Our New Openstack infrastructure running on Virtuozzo:

We are moving to a clustered storage system using all Enterprise SSD’s. Previously we used a mix of Sata, SCSI, and SSD’s running on a single SAN storage back-end.
We are no longer providing CPU share-based plans. Any customers with these plans will get upgraded for free. For example, customers that ordered a VPS with 2 cores and only 20% cpu share will be upgraded to 2 full cores for free.
Virtuozzo provides its own enhanced QEMU/KVM distribution tuned for high performance and reliability. The Virtuozzo team is among the top 10 committers to the QEMU/KVM project.
The Virtuozzo team supports and develops the Linux kernel.
Virtuozzo ReadyKernel enables rebootless updates of the host kernel to apply critical security updates.

Thank you again for choosing Joe's Datacenter
Host at Joe's
Posted Mar 07, 2021 - 00:08 CST
This incident affected: Cloud Infrastructure and VPS Infrastructure.