Joe's Datacenter Notification: Rolling Blackouts
Incident Report for Joe's Datacenter, LLC
Resolved
This incident has been resolved.
Posted Feb 17, 2021 - 10:26 CST
Update
We are continuing to monitor for any further issues.
Posted Feb 17, 2021 - 10:25 CST
Monitoring
Due to inclement weather, Evergy is doing rolling blackouts to ease the strain put on the electric grid in our region. We are testing our generators in preparation. Blackouts may occur from 30-60 minutes at a time. As we get more information, we will pass it along.
Posted Feb 15, 2021 - 14:43 CST
This incident affected: Billing/Ticket System, Power Infrastructure, and Joe's Datacenter Website.